If you are on update version 1.03.6g/h/i there is no need to upgrade to this version. If you are on 1.03.6j then NEVER downgrade your router as you WILL brick the router. You will automatically be on 1.03.6j if you ordered on or after 20/11/2017. 1.03.6j does not have any new features over 1.03.6g/h/i.


Following these instructions will help you update your NETDUMA router to the latest. You can find out what version you are on by going onto the NETDUMA interface and scrolling down to see the version you are on.


If you are on a version lower than .5 do not upgrade. Please post here so we can check your router.